Uploaded image for project: 'Jalview'
  1. Jalview
  2. JAL-3904

Structure window's viewer-specific menu disappears when many sequences:one chain mappings are present

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.11.1, 2.11.2
    • Fix Version/s: 2.11.2.0
    • Component/s: gui, Structures
    • Labels:
      None

      Description

      Noticed when working with alignments of repeat regions with Chimera, but also happens with ChimeraX.

      Simple test:
      >FER1_SPIOL/1-147
      ----MAATTTTMMGMATTFVPKPQAPPMMAALPSNTG-RSLFGLKT--GSRGGRMT-MAAYKVT
      >FER1_SPIOL/1-147
      LVTPTGNV
      EFQCPDDVYILDAAEEEGIDLPYSCRAGSCSSCAGKLKTGSLNQDDQSFLDDDQIDEGWVLTCAAYPVSDVT
      IETHKEEELTA-

      Import and discover structures.
      1. only one sequence gets the mapping to structure even though both could be (need a separate issue for this).
      2. Use 3d-structure chooser again to map second sequence to existing structure view.

      Problem: The Jmol/Chimera/ChimeraX menu is not shown, or if it was shown, it disappears after the second mapping is made.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jprocter Jim Procter
              Reporter:
              jsutges Javier Sanchez Utges
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: