Uploaded image for project: 'Jalview'
  1. Jalview
  2. JAL-4165

Missing last letter when copying consensus sequence from alignment after applying filter

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.10.4, 2.11.2.6, 2.11.3.0, 2.11.3.1
    • Fix Version/s: 2.11.3.2
    • Component/s: analysis, annotation
    • Labels:
    • Environment:
      Windows 10/11, AMD & Intel

      Description

      I opened the attached alignment file (H3N2-M2.aln, clustal format, zipped before upload), applied a column filter (Hide column by annotation) per attachment settings, and copied the consensus sequence. The last letter (E in this case) is correctly displayed in the consensus but missing from the copied version. This issue does not happen before application of column filter.
      Below is copied sequence:
      >Consensus/1-103 Percentage Identity Consensus
      MSLLTEVETPIRNEWGCRCNDSSDPLVVAANIIGILHLILWILDRLFFKCVYRLFKHGLKRGPSTEGVPESM
      REEYRKEQQNAVDADDSHFVSIEL
      Note the missing last letter "E".

        Attachments

        1. 1.png
          1.png
          70 kB
        2. H3N2-M2.zip
          738 kB

          Activity

            People

            Assignee:
            jprocter James Procter
            Reporter:
            azuretimm azuretimm
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: