Uploaded image for project: 'Jalview'
  1. Jalview
  2. JAL-3464

Version compliance / validation for JAXb based project import

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.11.0, 2.11.1, 2.11.1_js
    • Fix Version/s: 2.12.0
    • Component/s: Jalview Project
    • Labels:
      None

      Description

      Formally, we do not support projects created with newer versions of Jalview imported into an older version. Prior to release 2.11.0, this situation rarely happened since older versions of Jalview used Castor, which enforced strict schema compliance.

      Since JAXB does not enforce compliance a UI component will need to be shown warning users when potentially incompatible projects are imported rather than relying on the 'if an exception occurred, project import failed' logic currently in place.

        Attachments

          Activity

            People

            Assignee:
            jprocter Jim Procter
            Reporter:
            jprocter Jim Procter
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: